Loading issue for webpage markups in Google Chrome

Incident Report for MarkUp

Resolved

This incident has been resolved.
Posted Nov 30, 2023 - 11:11 UTC

Monitoring

An issue with recent Chrome update has been identified:
- we rely on `DOMContentLoaded` event being sent to drop the loading overlay for webpage MarkUps
- that event stopped getting fired for some Chrome users when dealing with iframes causing website to load behind the overlay, but overlay did not get removed

We deployed a fix:
- we updated the check to be performed both when event is fired and additional a backup interval check of `readyState` to address possible browser issues
- additionally we added a maximum timeout after which loading overlay is dropped automatically

We are looking into feedback from customers that faced this issue and hope that our solution did resolve this problem.
Posted Nov 22, 2023 - 12:03 UTC

Investigating

We are getting increased number of reports on website markups failing to load in Chrome browser.
As a workaround other browser can be used.
Posted Nov 16, 2023 - 21:18 UTC
This incident affected: Web Application.